Calculix:Initial Conditions

In the figure below, The base U shape is the Foundation which is fixed and Cuboid is fixed on the foundation. The plate is kept fixed on the ends. You can see the plate is intersecting with the cuboid and it has penetrated the cuboid surface. The purpose of doing this is to create an initial bending of plate , by giving a contact between cuboid and the plate. I want the value of stresses at the base of the cuboid and at the contact area of the foundation. Is it possible in calculix
hcpy_1.png
784 x 672 - 8K

Comments

  • If I had undertood well, you need to model the plate first without interescting the cuboid, and then by means of a static step move it (including contacts) in X direction to the final position to see the stress on the assembly. After the plate is on the "mounted design position", you can include further steps to add more loads on the assembly.
  • What do you mean by static steps.
  • The part of the calculus that do the loading.
  • To be a bit more specific - in the *STEP section Sergio mentioned, use *BOUNDARY to specify a displacement in the X direction that moves the plate. Also remove the existing zero X *BOUNDARY constraint on it.
  • Thanks Sergio &
  • edited January 20
    Thanks Sergio & Victor. I tried experimenting with the intersecting geometry. I tried to give a linear,no penetration contact between plate and cuboid and it showed stresses but I tried to validate it by changing the young's modulus of Plate to see if the displacement is logical or not but it turns out that its not.When I reduce the plate 's Young Modulus by the factor of 10,it is suppose to increase the displacement of plate in -x direction but it doesn't.What can be the reason. Here are the include files. 100_1Plate inp is the mesh inp file
    movie.gif
    784 x 672 - 388K
    inp
    inp
    add_boundary.inp
    0B
    inp
    inp
    add_contact.inp
    368B
    inp
    inp
    add_material.inp
    422B
    inp
    inp
    add_support.inp
    289B
    inp
    inp
    allinone.inp
    2M
    inp
    inp
    _main.inp
    412B
    inp
    inp
    100_1Plate.inp
    2M
  • It works OK for me. I used this plate material:

    *MATERIAL,NAME=Cplate
    *ELASTIC
    1.0000E+08,0.3

    and it caused double the displacement at the middle of the plate, compared to the original plate material with E=1e9.
    displacement increase.png
    1366 x 736 - 125K
  • edited January 20
    Thanks Victor, That reduces so many confusions I had. That means there is no problem with the inputs.If its not much trouble can you compare between 1e9 and 1 e10 PLATE 'S Youngs Modulus because its giving me trouble there.Victor Another thing, I am changing the pressure overclosure slope (K) with changing youngs modulus of CPLATE,i.e 50*E, So can that cause a significant change in result
  • The displacement is smaller with 1E10 as you'd expect. See attached picture.

    If K is changing the result, then it needs to be bigger. Make it as large as possible without causing it to fail or take too long to converge. You might have trouble with a big value of K in this setup where it starts in penetration because it would apply a very large force to push the plate out. If you find large K doesn't converge, you might need to go back to what Sergio suggested and start with the plate away from the cuboid then gradually move it against it, like what would happen in real life.
    plate 1e10.png
    684 x 736 - 69K
  • Thanks Victor. Yours result with 1E10 is correct according to hand calculation but CCX is showing different results than yours with 1 e+10 youngs modulus. DId you change anything from your side ? If not then do i have to use another build of ccx?
  • This is what I am getting for 0.1,1,10,100 Gpa Youngs Modulus.
    C_DISP_0.1.png
    784 x 672 - 10K
    C_DISP_1.png
    1535 x 876 - 13K
    C_DISP_10.png
    784 x 672 - 11K
    C_DISP_100.png
    1535 x 876 - 13K
  • No, I only changed E for the Cplate material. I left K at 5e10. Here are the files I used if you want to run it again.

    I agree your results seem wrong. The plate's deflection strangely increases when its stiffness increases from E=1 GPa to E=10 GPa. Did CCX say they all converged? It still outputs the failed result when there's no convergence.

    I wouldn't expect the build to affect this. I used the 2.11 that's included with Mecway 8.
  • file for previous post
    zip
    zip
    plate.zip
    1M
  • I ran your .inps file and it worked and It gave the correct results. So its not the problem of the solver. So it can be about convergence.But no matter how low i make the initial increment or increase the number of increments it gives the same result.Seriously,its odd.Our inputs are same but still its giving me so much trouble. I hope you can find out what the problem is.
    Screenshot from 2018-01-22 14-33-09.png
    1600 x 900 - 192K
  • Attached is the .cvg file, if it helps
    zip
    zip
    _main.cvg.zip
    815B
  • Hey,Victor. Problem Solved. It was a blunder from my part and so moronic that you would want to kill me. I kept the material same for plate and the cuboid so the value got misplaced. Thanks for all your effort.
  • That's the nature of these problems - there are so many ways for it to go wrong, you can't be sure until you isolate it.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!